Thylacine Studios - Forum

Slow and unresponsiveness after 1.2.0 update  (Read 6159 times)

Offline Zack

  • Administrator
  • *****
  • Posts: 3403
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #15 November 24, 2014, 07:33:00 PM
I promise, it's actually fixed this time. I'm compiling the update now and you should see it in about an hour from now. This also contains a few more fixes including everything people mentioned on the forums today.

Thanks for being patient and for providing so much detail on your bug reports, everyone.
« Last Edit: November 24, 2014, 07:42:01 PM by Zack »
Designer and Programmer of Siralim and The Negative. Follow us on: Facebook | Twitter | YouTube

Offline Shardz

  • *
  • Posts: 14
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #14 November 24, 2014, 07:05:59 PM
The A and B buttons work alright for me, though not as responsive as I remembered in the past. My main problem with the very latest patch is the D pad is all jacked up, especially pressing up and left directions. I noticed that the hotspots for those two directions appear to be close to the center dot. Sliding (swiping) out from the center position gets movement much better, but something is definitely awry with the D pad for me. It's difficult to play like this. BTW, the last patch was like #3 in 24 hours... Not sure if another version went up while I am writing this.

Siralim Android v1.2.3
Nexus 7 2012
Android version KitKat 4.4.4
« Last Edit: November 24, 2014, 07:08:21 PM by Shardz »

Offline Zack

  • Administrator
  • *****
  • Posts: 3403
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #13 November 24, 2014, 06:07:24 PM
I'll include that in tonight's fix then.
Designer and Programmer of Siralim and The Negative. Follow us on: Facebook | Twitter | YouTube

Offline Dangster

  • *
  • Posts: 6
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #12 November 24, 2014, 05:48:36 PM
Yes the delay is only a few seconds if it is intentional.

There is a new problem though. Every time I use a gem box, an error message pops up and the game crashes.
http://i.imgur.com/PdRN8i3.jpg

Offline Zack

  • Administrator
  • *****
  • Posts: 3403
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #11 November 24, 2014, 05:44:45 PM
How long is the delay? There's an intentional delay to prevent people from accidentally closing it too quickly, but it shouldn't be longer than a couple seconds.

Bewi: I'm still working on fixing the touch controls. Still hoping to have it fixed today.
Designer and Programmer of Siralim and The Negative. Follow us on: Facebook | Twitter | YouTube

Offline Dangster

  • *
  • Posts: 6
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #10 November 24, 2014, 05:42:06 PM
Problem seems to be fixed for me and the game is running smoothly again but there is still a delay when viewing a creature's artifact. After clicking on "view artifact" there's a delay before I could exit the viewing window. Most of the problem seems to be fixed though and the game is working great for me again. Thanks for the quick fix!

Offline Bewi

  • ***
  • Posts: 208
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #9 November 24, 2014, 04:18:17 PM
I'm sorry but the problem is still here with 1.2.3, even after rebooting my device.

Offline Zack

  • Administrator
  • *****
  • Posts: 3403
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #8 November 24, 2014, 12:57:49 PM
Uploading a fix now. Please let me know if it solved the problem for you.
« Last Edit: November 24, 2014, 01:18:16 PM by Zack »
Designer and Programmer of Siralim and The Negative. Follow us on: Facebook | Twitter | YouTube

Offline Zack

  • Administrator
  • *****
  • Posts: 3403
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #7 November 24, 2014, 11:45:54 AM
I've tested this on a few different devices and can't reproduce the issue. You might need to restart your device.

Edit: This problem is happening on my iPhone. I'll get this fixed quickly.
« Last Edit: November 24, 2014, 12:30:11 PM by Zack »
Designer and Programmer of Siralim and The Negative. Follow us on: Facebook | Twitter | YouTube

Offline Bewi

  • ***
  • Posts: 208
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #6 November 24, 2014, 10:59:35 AM
I'm afraid the 1.2.2 is bugged : I can't go past the very first screen where it displays the default controls. No button is responding (Android version).

Offline Bewi

  • ***
  • Posts: 208
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #5 November 24, 2014, 10:55:59 AM
The problem was caused by the colored text ? I can say it was not causing any slowness on Windows version though.

Offline Zack

  • Administrator
  • *****
  • Posts: 3403
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #4 November 24, 2014, 09:42:38 AM
It is fixed now.
Designer and Programmer of Siralim and The Negative. Follow us on: Facebook | Twitter | YouTube

Offline Zack

  • Administrator
  • *****
  • Posts: 3403
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #3 November 24, 2014, 07:45:29 AM
I'll get a fix out for this today.
Designer and Programmer of Siralim and The Negative. Follow us on: Facebook | Twitter | YouTube

Offline Bewi

  • ***
  • Posts: 208
    • View Profile
Re: Slow and unresponsiveness after 1.2.0 update
Reply #2 November 24, 2014, 03:35:03 AM
I have exactly the same problem on my HTC One and with version 1.2.1.

Offline Dangster

  • *
  • Posts: 6
    • View Profile
Slow and unresponsiveness after 1.2.0 update
Reply #1 November 23, 2014, 11:50:13 PM
I'm using the Samsung Galaxy Note 2 and after the 1.2. update came out, things became more sluggish. There are no problems with the movements around the realms in Siralim but when it comes to combat, everything seems to be a lot more unresponsive and slow from the last version. I used to be able to tap the "A" key to skip a text after I've read it but now there's a delay with every text so tapping the "A" key right away doesn't skip anything and I have to wait for the delay to pass to get through. Combat now takes considerably longer as I found out that the best way to deal with this new annoyance is to just hold down the "A" key and wait for everything to just finish by itself. This adds a lot of time to the combat phase. The menu seems to also have gotten more sluggish as well. Reordering the creatures or viewing the artifacts now all have the same weird delay that happens in combat. After every key press, I have to wait for the delay to pass before I can press a key and have it respond. I've tried restarting the game and my phone but things are still the same after the update 1.2.0 came out.